Code

Opened 9 years ago

Closed 7 years ago

#863 closed defect (wontfix)

Atom Feeds should pick up "updated" and "published" elements automatically from auto_now and auto_now_add fields

Reported by: matt@… Owned by: adrian
Component: contrib.syndication Version:
Severity: normal Keywords:
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Atom 1.0 requires each entry to have an "updated" element, which is the date of the last update. It also provides the optional "published" element. Both of these could easily be picked up from auto_now and auto_now_add DateField/DateTimeField types in the appropriate table, if they exist.

(When an auto_now is lacking, the auto_now_add should be used as both "updated" and "published", as "updated" is required.)

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by anonymous

It appears that you do put an updated element in the feed, but you don't put an updated element in each entry of the feed. Can feed.add_item() be extended for this.

comment:2 Changed 7 years ago by SmileyChris

  • Triage Stage changed from Unreviewed to Design decision needed

comment:3 Changed 7 years ago by mtredinnick

  • Resolution set to wontfix
  • Status changed from new to closed

We do have an "updated" element on each entry in the feeds now. So that part of the problem is taken care of. The other request -- trying to engineer the values from the assumption that an auto_now field is the right one -- looks like a bit too much of an assumption. On a semantic level, the "updated" element doesn't necessarily contain "last time it was touched at all"; it is intended as "last significant update", which often excludes things like minor typo editing.

I think this a bit too fragile to implement.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.