Code

Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#8606 closed (worksforme)

Attribute error in Exception handling - Oracle backend

Reported by: guneeyoufix Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Keywords: attribute,excpetion,message,database,oracle,backend
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

There is an error with the Oracle backend. Here is the trackback: http://dpaste.com/74192/
It works if 'message' is replaced by args[0], but there is probably a more elegant way to do it.
Last thing: I'm running Python 2.3, with no possibility to use a newer version.

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by guneeyoufix

  • Keywords attribute,excpetion,message,database,oracle,backend added; attribute,excpetion,message removed
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 follow-up: Changed 6 years ago by mtredinnick

What version of cx_Oracle are you using? That's where the problem is originating.

comment:3 Changed 6 years ago by jacob

  • Resolution set to worksforme
  • Status changed from new to closed

This is almost certainly an outdated version of cx_Oracle. Please check your version, asking django-users or in #django if you need help. If you can track this down to a bug that actually exists in Django, please feel free to reopen.

comment:4 in reply to: ↑ 2 Changed 6 years ago by guneeyoufix

Replying to mtredinnick:

What version of cx_Oracle are you using? That's where the problem is originating.

I'm using the 4.2.1-1 version of the package.

comment:5 Changed 3 years ago by jacob

  • milestone 1.0 deleted

Milestone 1.0 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.