Code

Opened 6 years ago

Closed 6 years ago

#8602 closed (duplicate)

Archive_week should accept Monday as the first day of the week

Reported by: Jusso Owned by: nobody
Component: Generic views Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Currently, the weeks in django.views.generic.date_based.archive_week start with Sunday. While this is common practice in the US, most of the rest of the world uses Monday as the first day of the week (which also happens to be an ISO standard), and the generic view isn't very useful in these countries.

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1061, but the real issue of having this local metadata available is going to be solved as part of #7980.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.