Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8592 closed (fixed)

Savepoints not completely disabled with PostgreSQL prior to 8.0.

Reported by: mlafon@… Owned by: nobody
Component: Database layer (models, ORM) Version: 1.0-beta
Severity: Keywords:
Cc: django@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I am using Django 1.0 beta 1 with PostgreSQL 7.4.

With mod_python, I have the following exception : ProgrammingError: syntax error at or near "SAVEPOINT" at character 1

Savepoints should be disabled with PostgreSQL < 8.0 (Changeset [8317]) but this does not work because it is not disabled in all DatabaseWrapper objects, only the first one. Surely because we are using a class member to store the fact that it has been disabled : self.__class__._version = version

The problem is not present when using manage.py runserver , surely because only one DatabaseWrapper will be created.

Change History (7)

comment:1 Changed 7 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from Savepoints non completely disabled with PostgreSQL prior to 8.0. to Savepoints not completely disabled with PostgreSQL prior to 8.0.

comment:2 Changed 7 years ago by mtredinnick

  • milestone set to 1.0

comment:3 Changed 7 years ago by jacob

  • Triage Stage changed from Unreviewed to Accepted

comment:4 Changed 7 years ago by Hangya

  • Cc django@… added

comment:5 Changed 7 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from new to closed

I believe this is fixed by [8648]. Please reopen if the problem still occurs (I don't have any way to test this at the moment, but a manual code inspection revealed a problem in the code).

comment:6 Changed 7 years ago by mlafon@…

I have verified that the problem is fixed with [8648], thanks.

comment:7 Changed 4 years ago by jacob

  • milestone 1.0 deleted

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.
Back to Top