Code

Opened 6 years ago

Closed 6 years ago

#8588 closed (duplicate)

Admin interface +'s are still displayed next to FK even if you dont have permission to add objects of that type.

Reported by: billsb Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In the admin if your logged in with a user that does not have permission to add a certain object referenced as FK in another model the plus sign is displayed next to the FK reference even though when you click on the plus sign it says 'permission denied'. It would be nice if + sign wasn't displayed if you don't have the correct permissions to add an object of that type.

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

dupe of #1035

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.