Code

Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#8533 closed (fixed)

Docs on model inheritance missing since r8506 (docs refactor)

Reported by: idangazit Owned by: nobody
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Following docs refactor, I believe that all of the information regarding model inheritance that used to live in model-api is missing.

To be clear, I'm talking about model inheritance from the "old" docs. Additionally, information about the Meta option abstract isn't present in [source:django/trunk/docs/ref/models/options.txt options.txt].

I don't know if this is by design, and can't find any tickets/changesets that indicate a change in behavior, so I think this is just a case of missing docs. If somebody can provide a positive indication that the old docs are still accurate, I'd be happy to copy the relevant missing sections into the new docs and provide a patch.

Attachments (0)

Change History (7)

comment:1 Changed 6 years ago by julien

  • milestone set to 1.0
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

This was reported again in #8667. This needs to be fixed by 1.0.

comment:2 Changed 6 years ago by julien

Just a few comments:

  • Since model inheritance is a quite big subject on his own, maybe would it deserve its own separate page in the docs? My guess is that it was the original idea to remove the "Model Inheritance" section from the Model doc and move it to a separate topic page, but the new page would have slipped through in the process. Could Jacob confirm that?
  • In the refactored docs, OneToOneField doesn't refer to parent_link any more, like it used to in the old docs.

comment:3 Changed 6 years ago by julien

Also stressing that, as pointed by idangazit above, it'd be worth to mention abstract in the Meta options page.

comment:4 Changed 6 years ago by julien

I've opened a separate ticket, #8701, to fix all the references to the old doc. So for this ticket ignore my note about the serialization doc.

comment:5 Changed 6 years ago by richardb

I've sent in a patch for #8701 that fixes references to old doc except for this missing documentation - this makes the problem slightly easier to handle.

When the missing docs have been reinstated, there are a number of old-style docs links that will then need updating
The files affected are:
docs/topics/serialization.txt
docs/topics/db/models.txt

I'd be happy to write a further patch when the model inheritance has been added back in.

comment:6 Changed 6 years ago by ubernostrum

  • Resolution set to fixed
  • Status changed from new to closed

(fixed in [8757])

comment:7 Changed 3 years ago by jacob

  • milestone 1.0 deleted

Milestone 1.0 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.