Code

Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#8434 closed (fixed)

[8443] broke tests

Reported by: jarrow Owned by: jarrow
Component: Internationalization Version: master
Severity: Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Tested on r8445, Debian Etch, Python 2.4.4

======================================================================
FAIL: Doctest: regressiontests.forms.tests.__test__.localflavor_nl_tests
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/django/test/_doctest.py", line 2180, in runTest
    raise self.failureException(self.format_failure(new.getvalue()))
AssertionError: Failed doctest test for regressiontests.forms.tests.__test__.localflavor_nl_tests
  File "/srv/lib/django-trunk/tests/regressiontests/forms/tests.py", line unknown line number, in localflavor_nl_tests

----------------------------------------------------------------------
File "/srv/lib/django-trunk/tests/regressiontests/forms/tests.py", line ?, in regressiontests.forms.tests.__test__.localflavor_nl_tests
Failed example:
    s.render('provinces', 'OV')
Expected:
    u'<select name="provinces">\n<option value="DR">Drente</option>\n<option value="FL">Flevoland</option>\n<option value="FR">Friesland</option>\n<option value="GL">Gelderland</option>\n<option value="GR">Groningen</option>\n<option value="LB">Limburg</option>\n<option value="NB">Noord-Brabant</option>\n<option value="NH">Noord-Holland</option>\n<option value="OV" selected="selected">Overijssel</option>\n<option value="UT">Utrecht</option>\n<option value="ZE">Zeeland</option>\n<option value="ZH">Zuid-Holland</option>\n</select>'
Got:
    u'<select name="provinces">\n<option value="DR">Drenthe</option>\n<option value="FL">Flevoland</option>\n<option value="FR">Friesland</option>\n<option value="GL">Gelderland</option>\n<option value="GR">Groningen</option>\n<option value="LB">Limburg</option>\n<option value="NB">Noord-Brabant</option>\n<option value="NH">Noord-Holland</option>\n<option value="OV" selected="selected">Overijssel</option>\n<option value="UT">Utrecht</option>\n<option value="ZE">Zeeland</option>\n<option value="ZH">Zuid-Holland</option>\n</select>'


----------------------------------------------------------------------
Ran 444 tests in 291.684s

FAILED (failures=1)

Attachments (2)

drenthe.diff (1.4 KB) - added by jarrow 6 years ago.
drenthe-translations.diff (13.1 KB) - added by arien 6 years ago.
patch for test and translation files

Download all attachments as: .zip

Change History (11)

comment:1 Changed 6 years ago by jarrow

  • Component changed from Uncategorized to Internationalization
  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from Tests fail for r8445 to Tests fail for r8445 (change in NL language file?)

Looks like we gained an h in Drente ;) If this was intentional, the patch is attached.

Changed 6 years ago by jarrow

comment:2 Changed 6 years ago by jarrow

  • Owner changed from nobody to jarrow
  • Status changed from new to assigned

Here is the evidence that the change was correct http://nl.wikipedia.org/wiki/Drenthe

comment:3 Changed 6 years ago by jarrow

  • Summary changed from Tests fail for r8445 (change in NL language file?) to [8443] broke tests

Ok, obviously this was [8443] ...

comment:4 Changed 6 years ago by julien

  • Resolution set to fixed
  • Status changed from assigned to closed
  • Triage Stage changed from Unreviewed to Ready for checkin

Yep, good catch ;)

Just a note about [8443], maybe it would have been good to fix the 35+ occurrences of 'Drente' in the locales. Is that worth a new ticket, or should that be left to the respective translators?

comment:5 Changed 6 years ago by julien

  • Resolution fixed deleted
  • Status changed from closed to reopened

Sorry, I must have messed with Trac, I didn't mean to set this as 'fixed'.

Changed 6 years ago by arien

patch for test and translation files

comment:6 Changed 6 years ago by arien

The above patch fixes all translation files that mentioned Drente.

One occurrence of Drente remains in the PO files: in Spanish Drente is used as the local name for this province and the translator for es-ar actually translated this string. (For the es locale this wasn't done, so there I updated the msgstr as well.)

comment:7 Changed 6 years ago by mtredinnick

Only the respective translators change PO files. They are never updated by anybody, since the translation also needs to be updated. If the translators are using any kind of translation memory software, the new spelling may bring up a recommended translation.

comment:8 Changed 6 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [8449]) Fixed #8434 -- I forgot to update the tests when committing [8443]. Thanks,
jarrow.

comment:9 Changed 3 years ago by jacob

  • milestone 1.0 deleted

Milestone 1.0 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.