Opened 7 years ago

Closed 7 years ago

#8423 closed (duplicate)

Implement time filters

Reported by: gnuvince Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Keywords: datetime filter hour minute second
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

As of r8442, it is possible to filter a queryset by year, month or day using the usual syntax:

Event.objects.filter(start_time__year=2008)
Article.objects.filter(pub_date__month=11, pub_date__day=3)

However, filters for hours, minutes and seconds were missing. I have added those in a patch for your consideration along with unit tests and documentation.

Change History (1)

comment:1 Changed 7 years ago by toke

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8424

Closing this because of availability of a patch in the other one.

Note: See TracTickets for help on using tickets.
Back to Top