Code

Opened 6 years ago

Closed 6 years ago

#8383 closed (duplicate)

TemporaryUploadedFile.seek function signature doesn't match what's expected

Reported by: vomjom Owned by: nobody
Component: File uploads/storage Version: master
Severity: Keywords:
Cc: vomjom@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In django/core/files/uploadedfile.py, TemporaryUploadedFile's seek function only takes an offset, but as in shown in http://docs.python.org/lib/bltin-file-objects.html it should also takes a whence argument.

It'd be far better if TemporaryUploadedFile's file-object functions were more similar to InMemoryUploadedFile in that they would pass all the arguments, like:

def seek(self, *args, **kwargs):
    return self._file.seek(*args, **kwargs)

And so on for the rest of the functions.

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by vomjom

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Oops, this looks like a dupe of #7769

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.