Code

Opened 6 years ago

Closed 6 years ago

#8366 closed (fixed)

Modify views regression tests fixtures to not contain forward references

Reported by: ramiro Owned by: nobody
Component: Testing framework Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation:
Needs tests: Patch needs improvement:
Easy pickings: UI/UX:

Description

The views regression tests can't be run under MySQL with InnoDB storage and other RDBMS like MS SQL Server suffering from the limitation of not being able to handle forward references in serialized data (see #3615). The attached patch to the fixtures simply moves the "Boris" Author object instance before the articles he authored without breaking anything else.

The proposed change is arguably brittle because nothing guarantees no newer forward references could be introduced with future test enhancements. But, meanwhile, it allows these, no DB related, tests to be exercised when running the suite against these DB backends.

Attachments (1)

views_tests_fixtures.diff (1.1 KB) - added by ramiro 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by ramiro

comment:1 Changed 6 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

(In [8465]) Fixed #8366: Modified a test fixture to remove an unnecessary forward reference. Thanks to Ramiro Morales for the suggestion.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.