Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#8357 closed (fixed)

Changeset 8385 broke UserAdmin's add_view

Reported by: evan_schulz Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

[8385] converted some template logic into python code directly not taking into account that the logic is assuming that certain context variables exist. This obviously wasn't a problem in the template, but is causing a number of KeyErrors in the new templatetag if the context vars it is looking for (adminform, inline_admin_formsets) don't exist. In particular it is throwing these errors when you try to add a new contrib.auth user since UserAdmin overrides the add_view method and doesn't set those context vars.

Attachments (1)

8357.diff (1.3 KB) - added by evan_schulz 8 years ago.
correction to original diff

Download all attachments as: .zip

Change History (6)

comment:1 Changed 8 years ago by Julien Phalip

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Triage Stage: UnreviewedAccepted

Changed 8 years ago by evan_schulz

Attachment: 8357.diff added

correction to original diff

comment:2 Changed 8 years ago by Brian Rosner

Resolution: duplicate
Status: newclosed

Duplicate of #8353

comment:3 Changed 6 years ago by Russell Keith-Magee

Resolution: duplicatefixed

(In [13113]) Fixed #8357 -- Clarified what constitutes activity when calculating session expiry. Thanks to timo for the patch.

comment:4 Changed 6 years ago by Russell Keith-Magee

(In [13114]) [1.1.X] Fixed #8357 -- Clarified what constitutes activity when calculating session expiry. Thanks to timo for the patch.

Backport of r13113 from trunk.

comment:5 Changed 5 years ago by Jacob

milestone: 1.0

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.
Back to Top