Code

Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#8328 closed (fixed)

[8240] contained undocumented backwards incompatible change

Reported by: mmulley Owned by: nobody
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Changeset [8240] added code to override the default widget for certain field types in the admin. This is a backwards incompatible change and should be listed on the doc page for such changes.

(I was using a custom field which subclassed IntegerField and specified its own custom widget, which I would guess isn't such a rare use case, and this change broke my code. My workaround was just to manually delete 'widget' from kwargs in the constructor for my field class, but the lack of documentation meant it took a while to track down the problem.)

Attachments (0)

Change History (7)

comment:1 Changed 6 years ago by Daniel Pope <dan@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

This is related to #8306.

comment:2 Changed 6 years ago by mtredinnick

It's a wiki page. Feel free to edit it.

comment:3 follow-up: Changed 6 years ago by ubernostrum

  • Resolution set to invalid
  • Status changed from new to closed

Indeed it is a wiki page; as such anyone with knowledge of the change can edit it, without needing a ticket sitting open here.

comment:4 in reply to: ↑ 3 Changed 6 years ago by Karen Tracey <kmtracey@…>

Replying to ubernostrum:

Indeed it is a wiki page; as such anyone with knowledge of the change can edit it, without needing a ticket sitting open here.

This ticket pointed out an undocumented backwards-incompatible change. The associated ticket/changeset show no indication that any backwards-incompatibility was intended. It hardly seems unreasonable to open a ticket in such a case, to get clarification as to whether it was intended and what the correct way to adapt to the change is. Nobody involved in making the change has commented to say one way or the other, or to say whether the stated workaround is the right way to adapt. Nor has the backwards-incompatible page been updated.

The problem still exists -- there is an undocumented backwards incompatible change -- yet the ticket has been closed (as invalid?) so that it will be on nobody's radar to fix. It's a valid problem, and it still exists for some other user to trip over. It shouldn't be swept under the rug in hopes the original reporter will have the initiative and enough knowledge to document it correctly.

comment:5 Changed 6 years ago by mtredinnick

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Triage Stage changed from Unreviewed to Accepted

Agreed. We seem to be documenting such changes even when the original existed only for a few days (over my strong objections), so this should be documented. That was what my original commenting was pointing to: I had hoped the reporter could have taken care of it and then closed the ticket.

comment:6 Changed 6 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:7 Changed 3 years ago by jacob

  • milestone 1.0 deleted

Milestone 1.0 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.