Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#8147 closed (fixed)

Development server reloading on Jython

Reported by: Leo Soto M. Owned by: nobody
Component: Core (Other) Version: master
Severity: Keywords: jython
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The existing development server reloading code uses a process forking approach, which works well on CPython but is not very applicable on Jython, where the JVM startup time and the loose of HotSpot optimizations caused by respawning the Jython process are not desiderable. Not to mention that some spawnve POSIX flags aren't supported yet.

So, I've implemented an alternative (and IMHO, simpler) reloader strategy for Jython, which is helped by Jython itself. The Jython bits have been recently commited so this will work out of the box.

It also includes a small refactoring of autoreload.py, to avoid code duplication.

Attachments (1)

jython-reloader.diff (2.9 KB) - added by Leo Soto M. 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by Leo Soto M.

Attachment: jython-reloader.diff added

comment:1 Changed 8 years ago by Malcolm Tredinnick

Resolution: fixed
Status: newclosed

(In [8235]) Made auto-reloading for the dev server a little more friendly in the Jython
case. Patch from Leo Soto. Fixed #8147.

In passing, also corrected a typo when reloading .pyo files. Fixed #8157.

comment:2 Changed 5 years ago by Jacob

milestone: 1.0 beta

Milestone 1.0 beta deleted

Note: See TracTickets for help on using tickets.
Back to Top