Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#80 closed defect (worksforme)

Browsing to http://127.0.0.1:8000 fails when running django-admin.py runserver

Reported by: pkropf@… Owned by: adrian
Component: contrib.admin Version:
Severity: critical Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Following the tutorial 2 instructions to run

django-admin.py runserver

causes the following to be shown in the browser:

There's been an error:

Traceback (most recent call last):

File "/usr/lib/python2.4/site-packages/django/core/handlers/wsgi.py", line 184, in get_response

callback, param_dict = resolver.resolve(path)

File "/usr/lib/python2.4/site-packages/django/core/urlresolvers.py", line 85, in resolve

raise Http404, app_path

Http404

This occurs on a Ubuntu 5.04 system running Python 2.4.1, Django SVN version 193.

Change History (2)

comment:1 Changed 10 years ago by anonymous

  • Resolution set to worksforme
  • Status changed from new to closed

DJANGO_SETTINGS_MODULE has to be correctly defined before running django-admin.py runserver. On Windows its done as:

set DJANGO_SETTINGS_MODULE=myproject.settings.admin

and Unix as:

export DJANGO_SETTINGS_MODULE=myproject.settings.admin

comment:2 Changed 10 years ago by pkropf@…

DJANGO_SETTINGS_MODULE has to be correctly defined before running django-admin.py runserver. On Windows its done as:

set DJANGO_SETTINGS_MODULE=myproject.settings.admin

and Unix as:

export DJANGO_SETTINGS_MODULE=myproject.settings.admin

Note: See TracTickets for help on using tickets.
Back to Top