Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#7916 closed (duplicate)

makemessages shouldn't translate applications already translated

Reported by: garcia_marc Owned by: garcia_marc
Component: Internationalization Version: master
Severity: Keywords:
Cc: Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: yes Patch needs improvement: yes
Easy pickings: UI/UX:

Description

When creating a django project, that I want to translate at project level (not application by application). Then, in my project I want to add a reusable/external application that is already translated (for example django-registration). The result is that in my project .po file I have all strings that are already translated in the external application.

I think that it should be avoided, and could be easily achieved by omitting applications with a locale directory.

Also if I want to copy django inside the project (that could be useful for version specific/patched installations), all django strings are included in my django.po file.

Attachments (2)

7916.diff (1005 bytes) - added by garcia_marc 7 years ago.
7916_v2.diff (1021 bytes) - added by garcia_marc 7 years ago.
Patch that fixes problem in a language specific way.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by garcia_marc

comment:1 Changed 7 years ago by garcia_marc

  • Needs documentation unset
  • Needs tests set
  • Patch needs improvement set

It could be better to make it language specific. So imagine that an application is translated in language A, but not B, but our project is translated to A and B. Then we should include all literals from that application in .po file for language B, but no A.

Attaching new patch for it.

Changed 7 years ago by garcia_marc

Patch that fixes problem in a language specific way.

comment:2 Changed 7 years ago by garcia_marc

  • Triage Stage changed from Unreviewed to Design decision needed

comment:3 Changed 7 years ago by ramiro

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7050. There, Malcolm also describes another related possible requirement to handle this multiple-app scenario in a consistent way.

comment:4 Changed 4 years ago by jacob

  • milestone 1.0 deleted

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.
Back to Top