Code

Opened 6 years ago

Closed 6 years ago

#7914 closed (fixed)

"ping_google" not a aviable as subcommand in manage.py

Reported by: bernd Owned by: nobody
Component: Contrib apps Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

On the documentation there is an example for using the "pinging-google-via-manage", but the subcommand "ping_google" doesn't exist in manage.py.

http://www.djangoproject.com/documentation/sitemaps/#pinging-google-via-manage-py

$ python manage.py ping_google [/sitemap.xml]
Unknown command: 'ping_google'
Type 'manage.py help' for usage.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by andreas@…

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Same here, the problem is most likely missing init.py files:

django/contrib/sitemaps/management/init.py
django/contrib/sitemaps/management/commands/init.py

I don't attach a patch since I do not think it would help out very much.

comment:2 Changed 6 years ago by Karen Tracey <kmtracey@…>

  • Triage Stage changed from Unreviewed to Accepted

I can confirm adding the __init__.py files allows the ping_google command to be found by manage.py.

comment:3 Changed 6 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

(In [8062]) Fixed #7914 -- Added some missing init.py files that were missed when the ping_google command was added. Thanks to bernd for the report.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.