Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7891 closed (worksforme)

Auth Test Suite not always valid

Reported by: tolano Owned by:
Component: contrib.auth Version: master
Severity: Keywords: testcase test authentication email not found
Cc: aribao@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hello, the PasswordReset TestCase is not always valid, specifically the:

def test_email_not_found(self):
        "Error is raised if the provided email address isn't currently registered"
        response = self.client.get('/password_reset/')
        self.assertEquals(response.status_code, 200)
        response = self.client.post('/password_reset/', {'email': 'not_a_real_email@email.com'})
        self.assertContains(response, "That e-mail address doesn't have an associated user account")
        self.assertEquals(len(mail.outbox), 0)

In my case, the url /password_reset/ doesn't exist.

Change History (3)

comment:1 Changed 7 years ago by tolano

  • Component changed from Uncategorized to Authentication
  • Needs documentation unset
  • Needs tests unset
  • Owner nobody deleted
  • Patch needs improvement unset

I forgot set the component to Authentication.

comment:2 Changed 7 years ago by mir

  • Resolution set to worksforme
  • Status changed from new to closed

Well, it works for me. Please post the settings you used for the test and re-open the ticket.

comment:3 Changed 7 years ago by russellm

I suspect this report is a duplicate of issue #7521, fixed in [7805].

Note: See TracTickets for help on using tickets.
Back to Top