Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#7867 closed (duplicate)

regressiontests.model_inheritance_regress fails on MySQL

Reported by: Chris Hasenpflug <djangoproject@…> Owned by: nobody
Component: Metasystem Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Getting this test failure on the official buildbot as well as the new build slaves.

======================================================================
FAIL: Doctest: regressiontests.model_inheritance_regress.models.__test__.API_TESTS
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/mcroydon/buildbot/djangoproject/trunk-2.4-mysql/build/django/test/_doctest.py", line 2180, in runTest
    raise self.failureException(self.format_failure(new.getvalue()))
AssertionError: Failed doctest test for regressiontests.model_inheritance_regress.models.__test__.API_TESTS
  File "/home/mcroydon/buildbot/djangoproject/trunk-2.4-mysql/build/tests/regressiontests/model_inheritance_regress/models.py", line unknown line number, in API_TESTS

----------------------------------------------------------------------
File "/home/mcroydon/buildbot/djangoproject/trunk-2.4-mysql/build/tests/regressiontests/model_inheritance_regress/models.py", line ?, in regressiontests.model_inheritance_regress.models.__test__.API_TESTS
Failed example:
    [sorted(d.items()) for d in dicts]
Expected:
    [[('name', u"Guido's House of Pasta"), ('serves_hot_dogs', True)]]
Got:
    [[('name', u"Guido's House of Pasta"), ('serves_hot_dogs', 1)]]
----------------------------------------------------------------------
File "/home/mcroydon/buildbot/djangoproject/trunk-2.4-mysql/build/tests/regressiontests/model_inheritance_regress/models.py", line ?, in regressiontests.model_inheritance_regress.models.__test__.API_TESTS
Failed example:
    [sorted(d.items()) for d in dicts]
Expected:
    [[('name', u"Guido's House of Pasta"), ('serves_gnocchi', True), ('serves_hot_dogs', True)]]
Got:
    [[('name', u"Guido's House of Pasta"), ('serves_gnocchi', 1), ('serves_hot_dogs', 1)]]
----------------------------------------------------------------------
File "/home/mcroydon/buildbot/djangoproject/trunk-2.4-mysql/build/tests/regressiontests/model_inheritance_regress/models.py", line ?, in regressiontests.model_inheritance_regress.models.__test__.API_TESTS
Failed example:
    [sorted(d.items()) for d in dicts]
Expected:
    [[('name', u"Guido's All New House of Pasta"), ('serves_hot_dogs', False)]]
Got:
    [[('name', u"Guido's All New House of Pasta"), ('serves_hot_dogs', 0)]]
----------------------------------------------------------------------
File "/home/mcroydon/buildbot/djangoproject/trunk-2.4-mysql/build/tests/regressiontests/model_inheritance_regress/models.py", line ?, in regressiontests.model_inheritance_regress.models.__test__.API_TESTS
Failed example:
    [sorted(d.items()) for d in dicts]
Expected:
    [[('name', u"Guido's All New House of Pasta"), ('serves_gnocchi', False), ('serves_hot_dogs', False)]]
Got:
    [[('name', u"Guido's All New House of Pasta"), ('serves_gnocchi', 0), ('serves_hot_dogs', 0)]]
----------------------------------------------------------------------
File "/home/mcroydon/buildbot/djangoproject/trunk-2.4-mysql/build/tests/regressiontests/model_inheritance_regress/models.py", line ?, in regressiontests.model_inheritance_regress.models.__test__.API_TESTS
Failed example:
    [sorted(d.items()) for d in dicts]
Expected:
    [[('name', u"Guido's All New House of Pasta"), ('serves_gnocchi', False), ('serves_hot_dogs', False)]]
Got:
    [[('name', u"Guido's All New House of Pasta"), ('serves_gnocchi', 0), ('serves_hot_dogs', 0)]]

Change History (2)

comment:1 Changed 7 years ago by jacob

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7190.

comment:2 Changed 4 years ago by jacob

  • milestone 1.0 beta deleted

Milestone 1.0 beta deleted

Note: See TracTickets for help on using tickets.
Back to Top