Code

Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#7827 closed (duplicate)

Admin change_view uses _default_manager in place of self.queryset()

Reported by: Alex Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The admin change_view uses self.model._default_manager in place of self.queryset(request).

Attachments (2)

admin-qs.diff (1.0 KB) - added by Alex 6 years ago.
Problem also exists in the delete_view, this fixes both.
admin-qs.2.diff (4.0 KB) - added by Alex 6 years ago.
Added some tests

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by Alex

Problem also exists in the delete_view, this fixes both.

comment:1 Changed 6 years ago by Alex

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Changed 6 years ago by Alex

Added some tests

comment:2 Changed 6 years ago by Alex

  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #7510.

comment:3 Changed 3 years ago by jacob

  • milestone 1.0 deleted

Milestone 1.0 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.