Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#7767 closed (fixed)

'Loading a template from an egg' Django test fails on Windows

Reported by: Ramiro Morales Owned by: nobody
Component: Template system Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

As of r7929 the tests/regressiontests/templates/loaders.py:EggLoader.test_existing test fails (and possibly has been failing since its implementation back in [7565]):

E:\proj\django\trunk\tests>..\..\..\django_test\django-tests.bat
======================================================================
ERROR: A template can be loaded from an egg
----------------------------------------------------------------------
Traceback (most recent call last):
  File "E:\proj\django\trunk\tests\regressiontests\templates\loaders.py", line 8
2, in test_existing
    contents, template_name = lts_egg("y.html")
  File "E:\proj\django\trunk\django\template\loaders\eggs.py", line 24, in load_
template_source
    raise TemplateDoesNotExist, template_name
TemplateDoesNotExist: y.html

The problem is located in the test itself and is related to the differences in path separator. The attached patch fixes it.

Attachments (1)

egg_templates_win32_fix.diff (941 bytes) - added by Ramiro Morales 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Ramiro Morales

comment:1 Changed 8 years ago by Sung-jin Hong

Component: UncategorizedTemplate system
Has patch: set
milestone: 1.0 beta
Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Triage Stage: UnreviewedAccepted

Looks good to me.

comment:2 Changed 8 years ago by Malcolm Tredinnick

Resolution: fixed
Status: newclosed

(In [8135]) Fixed #7767 -- Fixed template egg loading test for Windows systems.
Thanks, Ramiro Morales.

comment:3 Changed 5 years ago by Jacob

milestone: 1.0 beta

Milestone 1.0 beta deleted

Note: See TracTickets for help on using tickets.
Back to Top