Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#7740 closed (duplicate)

i18n with windows

Reported by: maxp0w3r Owned by: nobody
Component: Documentation Version: master
Severity: Keywords: i18n
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi,

I think you should mention that windows users should download and install GNU/WIN gettext from sourceforge, otherwise it is very tricky to find out why i18n is not working.

cheers

Daniel

Change History (6)

comment:1 Changed 7 years ago by serialx

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Good point.

comment:2 in reply to: ↑ description ; follow-up: Changed 7 years ago by Karen Tracey <kmtracey@…>

Replying to maxp0w3r:

I think you should mention that windows users should download and install GNU/WIN gettext from sourceforge, otherwise it is very tricky to find out why i18n is not working.

This is rather vague. What exactly doesn't work with the Python-included gettext? A quick test of French admin on my Windows box (vanilla Python 2.5.2)appears to work fine.

comment:3 in reply to: ↑ 2 Changed 7 years ago by ramiro

Replying to Karen Tracey <kmtracey@gmail.com>:

This is rather vague. What exactly doesn't work with the Python-included gettext? A quick test of French admin on my Windows box (vanilla Python 2.5.2)appears to work fine.

I think the OP isn't talking about the Python runtime gettext support but about the GNU gettext utilities (xgettext, msgfmt) used by the manage.py makemessages/compilemessages commands.

We could copy some info from the "Tools" section of the wiki:Localization wikipage.

comment:4 Changed 7 years ago by mir

  • milestone set to 1.0 beta

maxp0w3r, can you please clarify and help us out? Can you provide any specific instructions for Windows users?

I think it makes sense to put this into the beta milestone, since this problem is basically a blocker for Windows users. And I guess we want to have Windows beta testers!

comment:5 Changed 7 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1157.

comment:6 Changed 4 years ago by jacob

  • milestone 1.0 beta deleted

Milestone 1.0 beta deleted

Note: See TracTickets for help on using tickets.
Back to Top