Code

Opened 6 years ago

Closed 6 years ago

#7690 closed (wontfix)

obj.manytomanyrel = None no longer works, needs reference in BackwardsIncompatibleChanges

Reported by: dnordberg Owned by: nobody
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

It used to be that a manytomany relationship could be assigned to None, which would be the same as calling clear().

E.g. obj.manytomanyrel = None was the same as obj.manytomanyrel.clear().

I think this was also in the documentation.

Now I cant do obj.manytomanyrel = None. I can however do this, obj.manytomanyrel = [].

I think needs to be added to db-api and BackwardsIncompatibleChanges.

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by dnordberg

  • Component changed from Uncategorized to Documentation
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 6 years ago by jacob

  • Resolution set to wontfix
  • Status changed from new to closed

I honestly can't recall that this ever worked, but I'll take your word for it! However, it shouldn't have worked in the first place; the fact that it did was probably a bug.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.