Opened 7 years ago

Closed 7 years ago

#7642 closed (duplicate)

LazyStream raises SuspiciousOperation in newforms-admin with upload object edited inline

Reported by: bryan Owned by: nobody
Component: Uncategorized Version: master
Severity: Keywords: file upload
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I have a model called Listing, and a model called Photo containing an ImageField and a ForeignKey to Listing.

Listing is managed using newforms-admin with Photo edited inline, extra=3.

In this case, LazyStream in multipartparser.py raises SuspiciousOperation when saving a Listing in newforms-admin, whenever there are more than a couple Photos associated with a Listing. The exception gets raised regardless of whether new files are being uploaded.

The exception message is: The multipart parser got stuck, which shouldn't happen with normal uploaded files. Check for malicious upload activity; if there is none, report this to the Django developers.

Change History (2)

comment:1 Changed 7 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

This looks like a duplicate of #7635.

comment:2 Changed 7 years ago by bryan

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for pointing that out. Looks like #7635 is sufficiently similar.

Note: See TracTickets for help on using tickets.
Back to Top