Opened 7 years ago

Closed 7 years ago

#7624 closed (duplicate)

In non-project settings, syncdb fails when adding a superuser

Reported by: mtredinnick Owned by: nobody
Component: Core (Management commands) Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


I was just creating an initial database sync for a bunch of apps that don't have a standard project directory. So I did the natural syncdb

and everything went well until I answered "yes" to the "do you want to create a superuser?" question. The management program then wants to run the createsuperuser command and then it fails. Similar results when running with the environment variable set for the settings file a well.

Note that in all cases (I tried this on a few different arrangements with different apps), I am running from outside any of the app directories. It's the ultimate "a collection of apps plus a settings file" scenario that we encourage. Python paths are correct in all cases (if I use the same setup and use a setup, it works).

I can't see why this should be failing from a 15 minute poke at the code, but I'm pretty stupid. So maybe somebody else can work it out.

Change History (1)

comment:1 Changed 7 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Since this is essentially #5943 in another disguise, I'll close it as a dupe of that.

Note: See TracTickets for help on using tickets.
Back to Top