Opened 7 years ago

Closed 7 years ago

#7615 closed (fixed)

FastCGI socket mode dosn't work with NginX with SVN-7828

Reported by: zenz Owned by: nobody
Component: Uncategorized Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


The FastCGI socket mode dosn't work with NginX any more, but the TCP mode are OK.

Change History (2)

comment:1 Changed 7 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

I have a suspicion this is going to be caused by [7800]. I don't have any way to test this without installing a whole pile of stuff I don't have at the moment. Could you reverse the patch in [7800] (just that change; go back to the version of from [7799]) and see if it fixes the problem?

What I suspect is happening is that the socket file needs to be writable by the Nginx server and that might not be the case here. If so, the general solution isn't to revert [7800], since it's actually the right fix to the general problem (making all files world readable is bad). We probably have to make sure the socket file is in an appropriate group of something like that so that the webserver can write to it. Some reasearch on how other socket-based daemons (e.g. Apache + fastcgi) handle this will be required.

Of course, I could be completely off-base and this might be some other problem entirely. If so, find a revision that works, then split the difference and check the revision halfway between the one that works and the one that fails. Repeat, halving the difference each time until you find the revision that caused the breakage.

comment:2 Changed 7 years ago by zenz

  • Resolution set to fixed
  • Status changed from new to closed

Yes, thank you for your point out the mistake what I have made, mtredinnick
the Nginx is started by user www-data, but the django fastcgi started by other user. when I change it. the problem fixed.
with the old django SVN version, it's not a problme to start the fastcgi socket mode by different user.
I saw the changes in just after your notice.
Thank you again.

Note: See TracTickets for help on using tickets.
Back to Top