Opened 7 years ago

Closed 7 years ago

#7595 closed (duplicate)

manage.py syncdb --noinput --settings=foo does not work as expected (the order matters)

Reported by: slinkp Owned by: nobody
Component: Uncategorized Version: newforms-admin
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If you want to run manage.py with --noinput and use a different settings file, this works:

python manage.py syncdb --settings=my.settings.module --noinput

But if --noinput comes first, the --settings option is silently ignored!
Like this:

python manage.py syncdb --noinput --settings=my.settings.module

When run like that, it appears to work, but the user will later be unpleasantly surprised to discover that the default settings module was really used.

Change History (1)

comment:1 Changed 7 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6017.

Note: See TracTickets for help on using tickets.
Back to Top