Code

Opened 6 years ago

Closed 6 years ago

#7590 closed (fixed)

"The submitted file is empty." error caused by inconsistency in UploadedFile and InMemoryUploadedFile argument order.

Reported by: CollinAnderson Owned by: nobody
Component: Uncategorized Version: master
Severity: Keywords:
Cc: cmawebsite@… Triage Stage: Unreviewed
Has patch: no Needs documentation:
Needs tests: Patch needs improvement:
Easy pickings: UI/UX:

Description

"The submitted file is empty." newforms validation error comes up because there is an inconsistency in UploadedFile and InMemoryUploadedFile argument order.
Compare lines 23, 142, and 143 of http://code.djangoproject.com/browser/django/trunk/django/core/files/uploadedfile.py

This was introduced in [7814].

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by jacob

  • Resolution set to fixed
  • Status changed from new to closed

(In [7817]) Fixed #7590: made UploadedFile subclasses' init methods sane.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.