Opened 7 years ago

Closed 7 years ago

#7520 closed (duplicate)

Detailed make-messages behavior

Reported by: MihaiD Owned by: jezdez
Component: Internationalization Version: master
Severity: Keywords: make-messages, internationalization, i18n
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


Right now the i18n documentation states that "runs over the entire Django source tree [or project,application] and pulls out all strings marked for translation". What the documentation fails to point out is that strings are only searched for in .py and .html files. A few people, including myself, have had problems with not noticing this behavior. My suggestion is pointing out this gotcha in the documentation.

Change History (3)

comment:1 follow-up: Changed 7 years ago by telenieko

  • Component changed from Documentation to Internationalization
  • Needs documentation unset
  • Needs tests unset
  • Owner changed from nobody to jezdez
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

jezdez has somethings about make-messages on his to do. I'll assign this to him to see if he wants to deal with it.

Also, maybe it'd be nicer to have a parameter "--include-extensions=html,py" to allow users to specify extensions to check. (i.e.: If you have mail templates you'd like to have .txt scanned)

comment:2 in reply to: ↑ 1 Changed 7 years ago by MihaiD

Having a parameter would be most desirable. Otherwise I would have to tinker with

comment:3 Changed 7 years ago by ramiro

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5463

Note: See TracTickets for help on using tickets.
Back to Top