Code

Opened 6 years ago

Closed 6 years ago

#7449 closed (worksforme)

edit_inline with IntegerField cause error: 'int' object is unsubscriptable

Reported by: rudyryk <alexey.rudy@…> Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: alexey.rudy@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'm using revision 7631, latest for now.

Error occurs in both cases: when creating and editing new object. Models are taken from tutorial. See traceback and code below.

Traceback:
File "C:\Python25\Lib\site-packages\django\core\handlers\base.py" in get_response
  82.                 response = callback(request, *callback_args, **callback_kwargs)
File "C:\Python25\Lib\site-packages\django\contrib\admin\views\decorators.py" in _checklogin
  62.             return view_func(request, *args, **kwargs)
File "C:\Python25\lib\site-packages\django\views\decorators\cache.py" in _wrapped_view_func
  44.         response = view_func(request, *args, **kwargs)
File "C:\Python25\Lib\site-packages\django\contrib\admin\views\main.py" in add_stage
  264.             new_object = manipulator.save(new_data)
File "C:\Python25\Lib\site-packages\django\db\models\manipulators.py" in save
  173.                         if f.core and not isinstance(f, FileField) and f.get_manipulator_new_data(rel_new_data, rel=True) in (None, ''):
File "C:\Python25\lib\site-packages\django\db\models\fields\__init__.py" in get_manipulator_new_data
  363.             return new_data.get(self.name, [self.get_default()])[0]

Exception Type: TypeError at /admin/my_hello/poll/add/
Exception Value: 'int' object is unsubscriptable
from django.db import models
import datetime

# Create your models here.

class Poll(models.Model):
        question = models.CharField(max_length=200)
        pub_date = models.DateTimeField('date published')
        class Admin:
                pass
        def __unicode__(self):
                return self.question

class Choice(models.Model):
        poll = models.ForeignKey(Poll, edit_inline=models.TABULAR, min_num_in_admin=3)
        choice = models.CharField(max_length=200, core=True)
        votes = models.IntegerField(core=True, default=0)
        class Admin:
                pass    
        def __unicode__(self):
                return self.choice

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this, also using r7631 with the sqlite3 backend and using exactly the same models.py file. Please post this report to the dango-users list or the #django IRC channel with additional details.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.