Opened 7 years ago

Closed 7 years ago

#7440 closed (duplicate)

regressiontests/dispatch/test_dispatcher assumes instantaneous gc

Reported by: leosoto Owned by: nobody
Component: Testing framework Version: master
Severity: Keywords: jython
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

test_dispatcher fails on Jython because there the gc is not "instantaneous" as on CPython.

The attached patch forces a garbage collection when running under Jython.

Attachments (1)

test_dispatcher_jython_gc.patch (1.5 KB) - added by leosoto 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by leosoto

comment:1 Changed 7 years ago by leosoto

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Oops, this was reported before on #7339. Marking as duplicate.

Note: See TracTickets for help on using tickets.
Back to Top