Opened 7 years ago

Closed 7 years ago

#7409 closed (duplicate)

Characters '/' and ':' cause issues when used within a field as the primary key.

Reported by: Richard Bell <rbell01824@…> Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When a CharField is used as the primary key and the value contains the characters '/' or ':' Django admin interface gets confused when adding a record and issues a 404 error.

Change History (1)

comment:1 Changed 7 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5041/#5490, depending on the branch in use. #5041 was closed wontfix due to concentrating effort on newforms-admin; #5490 is a blocker on merging newforms admin.

Note: See TracTickets for help on using tickets.
Back to Top