Code

Opened 6 years ago

Closed 6 years ago

#7288 closed (wontfix)

Create either a tutorial or helper module to wire up serialized django models and dojo grids

Reported by: Kevin Kubasik <kevin@…> Owned by: nobody
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Right now there are several 'power ajax grid' plugins for AJAX toolkits, and while django has chosen not to implement ajax in the framework, the django serialization framework is a crucial component of any dynamic application. The problem is, right now the boilerplate serialization code produces json that is almost impossible to use in any traditional databinding endeavor.

from django.core import serializers
data = serializers.serialize('json', KModel.objects.all())

while supporting one framwork in the API probably isn't the way we want to go, providing a little more guidance on how to best utilize the resulting json/xml in existing toolkits for simple solutions would go a long way towards easing the learning curve on new developers.

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to wontfix
  • Status changed from new to closed

This is outside the scope of Django and of Django's official documentation. If you'd like, though, feel free to write up a tutorial and list it on a relevant page of the Django wiki.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.