Opened 7 years ago

Closed 7 years ago

#7279 closed (duplicate)

Form wizard get_template bug

Reported by: nathan@… Owned by: nobody
Component: contrib.formtools Version: master
Severity: Keywords:
Cc: redvasily@… Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The FormWizard calls get_template(self, step) with the wrong step.

The code calls it with self.step, but self.step never gets updated after each step. It always stays 0 and so the get_template will always return the same value regardless of the step. The code doesn't seem to use self.step otherwise and so I developed a patch based on that fact.

Attachments (1)

wizard.diff (560 bytes) - added by anonymous 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by anonymous

comment:1 Changed 7 years ago by anonymous

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 7 years ago by redvasily

  • Cc redvasily@… added

comment:3 Changed 7 years ago by hanne.moa@…

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6893

Note: See TracTickets for help on using tickets.
Back to Top