Code

Opened 6 years ago

Closed 6 years ago

#7234 closed (duplicate)

Processing of If-Modified-Since does not work

Reported by: Romamo Owned by: nobody
Component: Core (Other) Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I have found a bug in django.middleware.http.ConditionalGetMiddleware
Lines 22 and 29
Instead of

response.status = 304

must be

response.status_code = 304

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Romamo

  • Has patch unset
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

In addition line 26 must be extended to

if if_modified_since and if_modified_since.partition(';')[0] == responseLast-Modified?:

comment:2 Changed 6 years ago by Simon Greenhill

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #7046.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.