Opened 7 years ago

Closed 7 years ago

#7134 closed (duplicate)

TestCase class hardcodes verbosity

Reported by: emperorcezar Owned by: nobody
Component: Testing framework Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


In the TestCase class django.test.testcases the run method on TestCase hardcodes the verbosity for loading a fixture to 0. This creates complications with loading a tests fixtures if there is an error E.g. Can't find the fixture.

This is a bug because the verbosity setting for the test run isn't passed, so if someone wants to check if their fixture loaded correctly, they have to add it to their tests, or use an alternate TestCase class.

Change History (1)

comment:1 Changed 7 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4371.

Note: See TracTickets for help on using tickets.
Back to Top