Code

Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#7108 closed (duplicate)

Documentation incorrect: The Response objects returned by TestClient DO NOT have a "headers" property

Reported by: dstn@… Owned by: nobody
Component: Documentation Version: master
Severity: Keywords:
Cc: dstn@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Section http://www.djangoproject.com/documentation/testing/#testing-responses claims that headers is a property of the Response objects returned by the test client's post() and get() methods, but this is not true.

(As of SVN rev 7500)

I have filed this as a documentation bug, but personally I would prefer if that functionality reappeared!

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by telenieko

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

[7500] is a newforms-admin merge, are you sure this is the right rev?

comment:2 Changed 6 years ago by programmerq

  • Triage Stage changed from Unreviewed to Accepted

comment:3 Changed 6 years ago by mir

  • milestone set to 1.0

comment:4 Changed 6 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7583, fixed in [7900]

comment:5 Changed 3 years ago by jacob

  • milestone 1.0 deleted

Milestone 1.0 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.