Opened 7 years ago

Closed 6 years ago

#7071 closed (duplicate)

Allow to change form class for password change view

Reported by: m.gajda@… Owned by: nobody
Component: Contrib apps Version: master
Severity: Keywords: contrib auth password change form override
Cc: Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I would like to have possibility to change form used by password change view. This is elegant way to provide own functionality into view without need to rewrite it. django-registration application allows it in its views, so one can override forms in url dispatch modules directly.
Desired functionality could be achieved using attached patch.

This ticket is similar to the #6905 one. It proposes the same change for another view.

Attachments (2)

password-change-override-form.patch (853 bytes) - added by m.gajda@… 7 years ago.
password_change_form.patch (1.2 KB) - added by rvanlaar 7 years ago.
Improved patch and working patch

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by m.gajda@…

comment:1 Changed 7 years ago by programmerq

  • Needs documentation set
  • Needs tests unset
  • Patch needs improvement set
  • Triage Stage changed from Unreviewed to Design decision needed

Changed 7 years ago by rvanlaar

Improved patch and working patch

comment:2 Changed 6 years ago by rvanlaar

  • Needs documentation unset
  • Patch needs improvement unset

comment:3 Changed 6 years ago by lukeplant

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8274

Note: See TracTickets for help on using tickets.
Back to Top