Opened 7 years ago

Closed 7 years ago

#7003 closed (duplicate)

Permalink documentation doesn't mention you can use named urls

Reported by: DavidReynolds Owned by: DavidReynolds
Component: Documentation Version: master
Severity: Keywords: models
Cc: david@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I think it would be useful to mention in the permalink documentation in model-api that you can use a named url in place of a view name.

So, for example:

def get_absolute_url(self):
    return ('people_detail', [str(self.id)])
get_absolute_url = permalink(get_absolute_url)

Would find a url like this:

url(r'^people/(\d+)/$', 'people.views.details', name='people_detail'),

Attachments (1)

7003-permalink-docs.diff (1012 bytes) - added by DavidReynolds 7 years ago.
Documentation patch

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by DavidReynolds

Documentation patch

comment:1 Changed 7 years ago by DavidReynolds

  • Needs documentation unset
  • Needs tests unset
  • Owner changed from nobody to DavidReynolds
  • Patch needs improvement unset

comment:2 Changed 7 years ago by DavidReynolds

Added a quick stab at this myself.

comment:3 Changed 7 years ago by Simon Greenhill

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7216 (which I saw first, even though it's more recent!)

Note: See TracTickets for help on using tickets.
Back to Top