Code

Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#7 closed defect (fixed)

Patch: Changelist date range filters don't maintain state as expected

Reported by: wilson Owned by: adrian
Component: contrib.admin Version:
Severity: minor Keywords:
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by wilson)

The changelist filter by a date doesn't behave as expected.

What happens: When I click "This month", it correctly displays the objects for this month and drills down the date nav to the appropriate context, but the filter on the right does not indicate which range is currently applied. The "Any date" link does not reset the date drill down.

What should happen: The date filter on the sidebar should update to show which range is currently applied. The "Any date" option should reset the date context. Alternatively, the filter "by date" options could be removed entirely to avoid conflict with the date drilldown.

Attachments (1)

filter.diff (798 bytes) - added by Manuzhai 9 years ago.
Get the correct fieldname for the current filter.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by wilson

  • Description modified (diff)
  • Reporter changed from adrian to wilson

comment:2 Changed 9 years ago by Manuzhai

I think this only happened when there were additional filters defined. The attached patch will fix this.

The issue is that a fieldname is used which is not used in the forloop, so that it will only ever use the last fieldname from an earlier loop.

Changed 9 years ago by Manuzhai

Get the correct fieldname for the current filter.

comment:3 Changed 9 years ago by Manuzhai

  • Summary changed from Changelist date range filters don't maintain state as expected to Patch: Changelist date range filters don't maintain state as expected

Changing summary to attract developers' attention to this patch.

comment:4 Changed 9 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

(In [417]) Fixed #7 -- Fixed subtle admin changelist filter bug in maintaining state. Thanks for the patch, Manuzhai!

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.