Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#698 closed defect (duplicate)

Exceptions thrown after CONTROL-C typed to stop test web server.

Reported by: Tekhne Owned by: adrian
Component: Core (Management commands) Version:
Severity: normal Keywords:
Cc: pete.crosier@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by jacob)

I received the following exceptions after attempting to stop the built-in test server with CONTROL-C:

shell> django-admin.py runserver
Validating models...
0 errors found.

Starting server on port 8000 with settings module 'myproject.settings'.
Go to http://127.0.0.1:8000/ for Django.
Quit the server with CONTROL-C (Unix) or CTRL-BREAK (Windows).
[26/Oct/2005 09:43:53] "GET /admin/ HTTP/1.1" 200 1615
[26/Oct/2005 09:44:00] "POST /admin/ HTTP/1.1" 302 0
[26/Oct/2005 09:44:00] "GET /admin/ HTTP/1.1" 200 5899
Error in atexit._run_exitfuncs:
Traceback (most recent call last):
  File "/usr/local/python-2.4.1/lib/python2.4/atexit.py", line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "/usr/local/python-2.4.1/lib/python2.4/threading.py", line 636, in __exitfunc
    self._Thread__delete()
  File "/usr/local/python-2.4.1/lib/python2.4/threading.py", line 522, in __delete
    del _active[_get_ident()]
KeyError: 1076103392
Error in sys.exitfunc:
Traceback (most recent call last):
  File "/usr/local/python-2.4.1/lib/python2.4/atexit.py", line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "/usr/local/python-2.4.1/lib/python2.4/threading.py", line 636, in __exitfunc
    self._Thread__delete()
  File "/usr/local/python-2.4.1/lib/python2.4/threading.py", line 522, in __delete
    del _active[_get_ident()]
KeyError: 1076103392

Change History (5)

comment:1 Changed 10 years ago by adrian

Yeah, this happens sometimes; it has to do with the auto-reloading of code. It doesn't really cause any problems other than ugliness (and scariness), but I'd love to see a patch that fixes the problem.

comment:2 Changed 10 years ago by jacob

  • Description modified (diff)

(fixed formatting)

comment:3 Changed 9 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

This doesn't appear to be happening anymore in the magic-removal branch.

comment:4 Changed 9 years ago by Pete Crosier

  • Cc pete.crosier@… added
  • Resolution fixed deleted
  • Status changed from closed to reopened

This has just started happening to me today, on auto dev. server reloading and Ctrl. + C'ing out of it, using manage.py runserver;

Error in atexit._run_exitfuncs:
Traceback (most recent call last):
  File "/usr/lib/python2.4/atexit.py", line 24, in _run_exitfuncs
oxxes@monkeynut:~/dev/django_projects/action_park/action_park_site$     func(*targs, **kargs)
  File "/usr/lib/python2.4/threading.py", line 638, in __exitfunc
    self._Thread__delete()
  File "/usr/lib/python2.4/threading.py", line 522, in __delete
    del _active[_get_ident()]
KeyError: -1209690432
Error in sys.exitfunc:
Traceback (most recent call last):
  File "/usr/lib/python2.4/atexit.py", line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "/usr/lib/python2.4/threading.py", line 638, in __exitfunc
    self._Thread__delete()
  File "/usr/lib/python2.4/threading.py", line 522, in __delete
    del _active[_get_ident()]
KeyError: -1209690432

comment:5 Changed 9 years ago by mtredinnick

  • Resolution set to duplicate
  • Status changed from reopened to closed

Let's call this a dupe of #2330, since there's a patch over there.

Note: See TracTickets for help on using tickets.
Back to Top