Code

Opened 6 years ago

Closed 6 years ago

#6975 closed (duplicate)

Feature request: allow blocks to appear more than once

Reported by: MihaiD Owned by: nobody
Component: Template system Version: master
Severity: Keywords:
Cc: template,block,multiple Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Wouldn't it be nice if a template accepted multiple appearances of a block?

I'm thinking of declaring a {% block <name> %} in a template and then extending another template where {% block <name> %} appears more than once.

Sometimes you need identical content displayed in multiple regions of a web page. As the system works now I would have to define two blocks for this and every time I make a change to one of them, remember to change the other. A bit redundant.

Thanks

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4529. Please search the tracker for existing issues before filing a new one.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.