Code

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#692 closed defect (invalid)

TemplateSyntaxError in admin with development server

Reported by: danlipsitt+djangotrac@… Owned by: adrian
Component: Core (Management commands) Version:
Severity: major Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I have replicated the error I described in this newsgroup posting on a different machine running a different Linux distribution, so I am filing it as a bug.

Error Description

As soon as log in to the admin interface (running on the development server), I get a traceback ending in this error:

  File "/usr/lib/python2.4/site-packages/django-1.0.0-py2.4.egg/django/core/template/defaulttags.py", line 627, in do_load
    raise TemplateSyntaxError, "'%s' is not a valid tag library" % taglib

TemplateSyntaxError: 'log' is not a valid tag library

Steps to Replicate

  1. Delete old django egg directory from site-packages.
  2. svn update to current trunk (I have tried [992] on one machine and [1006] on the other. I was using ~[882] before. This means I am updating to the admin changes of #627).
  3. setup.py clean, build, and install
  4. django-admin.py startproject myproject
  5. edit myproject/settings.py (use sqlite3, add admin to INSTALLED_APPS)
  6. enable admin in myproject/urls.py
  7. cd myproject
  8. django-admin.py startapp myapp
  9. rm -r myapp/settings
  10. django-admin.py init
  11. django-admin.py createsuperuser
  12. django-admin.py runserver my external ip:8000 --settings='myproject.settings'
  13. log in to the admin site

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by danlipsitt+djangotrac@…

I checked out a fresh copy of the django code from svn and everything works now. So the problem is that svn update left me with an inconsistent source tree. This ticket should be closed, but first I want to ask: is this a peril that should be mentioned in the install docs? Is there a flag that I should have used for svn update?

comment:2 Changed 8 years ago by sune.kirkeby@…

  • Resolution set to invalid
  • Status changed from new to closed

It is mentioned in the docs. See BackwardsIncompatibleChanges:

Delete django/templatetags/*.pyc and django/templatetags/*.pyo, just to be safe.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.