Code

Opened 6 years ago

Closed 6 years ago

#6878 closed (duplicate)

Add ordering to newforms classes

Reported by: dcramer Owned by: nobody
Component: Forms Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'd like to propose adding an ordering attribute to a Meta class in newforms to allow overriding the field ordering for things like as_p.

e.g.

class Form:
    name = Char
    text = Char

    class Meta:
        ordering = ('text', 'name')

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5986, which has several proposals and recent activity.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.