Code

Opened 6 years ago

Closed 6 years ago

#6800 closed (invalid)

Strange CGI error

Reported by: olafura@… Owned by: nobody
Component: Core (Other) Version: master
Severity: Keywords: cgi
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I get an error when I'm trying to serve webpages with django through cgi.
I have tried fcgi.py and plain wsgi and I get the same error.
The same with 0.96 and svn.
I also tried it with a hello world project and a production code, both
work with runserver.

Attachments (2)

shorterror.txt (811 bytes) - added by Olafur Arason <olafura@…> 6 years ago.
longerror.txt (12.1 KB) - added by Olafur Arason <olafura@…> 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by Olafur Arason <olafura@…>

Changed 6 years ago by Olafur Arason <olafura@…>

comment:1 Changed 6 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

Please take this to the django-users mailing list and explain what you are doing to recreate the error. Django isn't intended to work with cgi, so that case is uninteresting and it does work with fastcgi and wsgi, so it's not completely broken there. Thus there's something special about what you're doing. A ticket isn't the right place to debug that.

comment:2 Changed 6 years ago by Olafur Arason <olafura@…>

  • Component changed from Uncategorized to Core framework
  • Resolution invalid deleted
  • Status changed from closed to reopened

The problem is in the core, and even though you say that django isn't supposed to be used in cgi mode,
I would say that most hosting services have only that option. As you can see on you own page when
dealing with hosting services. You can mark this as a feature request or just show me where to look
to fix it, I know how to code. Just don't duck you head in the sand and say this does not exist.

And I have tried the irc, the -devel list and I don't want yet an other venue to try to get this
fixed.

And this is a problem in django, I can make python cgi scripts work quite well.

comment:3 Changed 6 years ago by mtredinnick

  • Resolution set to invalid
  • Status changed from reopened to closed

Fact of life: Django is not intended to work with cgi and we have decided not to include any extra code that is only for supporting cgi. In the past, some people have hacked it to do so, but that's external to Django. That is no longer up for debate.

Now, as I said in the original comment, it's not that every time somebody uses wsgi or fastcgi Django fails to serve any results, so there is something special about your setup. Since you don't describe the steps you are doing, it's very difficult to debug. Since working out which steps are relevant might take a few attempts, I'm asking you to have that back and forth on the mailing list, since a ticket tracker is a very poor place to do that. It's not clear that there is a bug here yet, it might be a setup problem.

So, if you are unable to make your project work with fastcgi or wsgi, please first ask for help by providing a short example that is causing the problem. The error files you atatch only report the final error. They don't show what you did to arrive at that point or what your setup might be. Then, we'll either be able to work out the setup problem or we'll know what the bug is and we can open a ticket with the details.

In the meantime, I am reclosing this because it seems to be asking for CGI support, which we aren't going to do. Please follow the request in contributing.txt and do not reopen the ticket. Otherwise we'll just end up going around in circles all day. The contributing file has information about what to do if you want to go further.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.