Code

Opened 6 years ago

Closed 6 years ago

#6671 closed (duplicate)

modifying the request object with middleware

Reported by: mpede Owned by: nobody
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

There is a cool feature where if you add a urlconf property to the request object passed to your process_request function of your middleware object it will look to that property to determine what gets passed to the URL resolver.

This is really nice to take advantage of, but perhaps it deserves to be a documented feature of something custom Middleware can do. Documenting this and perhaps other things like it I haven't found would really be useful for some people.
I'd also like to know that this feature isn't going to go away. Documenting it would definitely make this concern go away.

Thanks a lot for your work on Django! I'd like to find a way for our workplace to contribute back to this project.

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #6382.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.