Opened 7 years ago

Closed 3 years ago

#6610 closed New feature (duplicate)

don't hardcode flup fastcgi traceback off

Reported by: jedie Owned by: michel
Component: Core (Other) Version: master
Severity: Normal Keywords: fastCGI, flup
Cc: django@… Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: yes
Easy pickings: no UI/UX: no

Description

In [4170] the flup traceback are hardcoded turn off. I think this is not the best way.
The Traceback should be per default disable. But it should be possible to turn the traceback on via runfastcgi() options.

Attachments (2)

patch.txt (678 bytes) - added by jedie 7 years ago.
trac-6610.diff (2.1 KB) - added by michel 7 years ago.
Allow to specify a debug parameter to runfcgi that is passed to flup and allows for traceback pages. Default is False.

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by jedie

comment:1 Changed 7 years ago by jedie

  • Cc django@… added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 7 years ago by PhiR

  • Needs documentation set
  • Patch needs improvement set

It seems your patch doesn't allow setting the option. The value gets lost because it sits in fcgi_options and is never copied to wsgi_options. Plus you didn't document the extra command-line argument.

comment:3 Changed 7 years ago by programmerq

  • Triage Stage changed from Unreviewed to Accepted

Changed 7 years ago by michel

Allow to specify a debug parameter to runfcgi that is passed to flup and allows for traceback pages. Default is False.

comment:4 Changed 7 years ago by michel

  • Needs documentation unset
  • Patch needs improvement unset

I updated my patch to include documentation.

comment:5 Changed 7 years ago by michel

  • Owner changed from nobody to michel
  • Status changed from new to assigned

comment:6 Changed 4 years ago by julien

  • Type set to New feature

comment:7 Changed 4 years ago by patchhammer

  • Easy pickings unset
  • Patch needs improvement set
  • Severity set to Normal

trac-6610.diff fails to apply cleanly on to trunk

comment:8 Changed 3 years ago by claudep

  • Resolution set to duplicate
  • Status changed from assigned to closed
  • UI/UX unset

Duplicate of #8895

Note: See TracTickets for help on using tickets.
Back to Top