Code

Opened 6 years ago

Closed 6 years ago

#6601 closed (duplicate)

contenttypes documentation typos

Reported by: anonymous Owned by: nobody
Component: Documentation Version: master
Severity: Keywords: contenttypes doc typo
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Typo 1

The following code snippet from http://www.djangoproject.com/documentation/contenttypes/#generic-relations will raise an ImportError:

>>> from django.contrib.models.auth import User
Traceback (most recent call last):
  File "<console>", line 1, in <module>
ImportError: No module named models.auth

Apparently, this is what is actually meant:

>>> from django.contrib.auth.models import User
>>>

Typo 2

Also, near the end of the page,

>>> b = Bookmark('http://www.djangoproject.com/')
>>> b.save()
..
IntegrityError: datatype mismatch
>>>

appears to be missing a kwarg:

>>> b = Bookmark(url='http://www.djangoproject.com/')
>>> b.save()
>>> 

}}}

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Collin Grady <cgrady@…>

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6600

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.