Opened 8 years ago

Closed 8 years ago

#6562 closed (fixed)

easy_install missing templates/media dir of admin

Reported by: zodman Owned by: nobody
Component: Tools Version: master
Severity: Keywords: install easy_install template dir
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

im install the r7095 of django. with easy_install like a python egg

And i see:

the templates/ and/or media/ dir of django/contrib/admin/, django/contrib/databrowser, django/contrib/formtools/, django/contrib/comments/ is not is copy to the Django-0.97_pre-py2.4.egg/ dir

Attachments (1)

6562.diff (967 bytes) - added by Karen Tracey <kmtracey@…> 8 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 8 years ago by Karen Tracey <kmtracey@…>

  • Component changed from Uncategorized to Tools
  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Root cause is probably the same as the missing templates/media (really all data files) often reported on Windows installs. I'll attach a patched setup.py that fixes the problem. Per advice on how to fix it from Malcolm, new setup.py chdir's into the location of setup.py and then builds all file paths relative to that root. I tested the fix on:

Windows XP, using both the 'python setup.py install' and 'setup.py install' variants, both when current directory was and was not the location of setup.py, all with Python 2.5.1.

Linux (Ubuntu Gutsy), again both with and without the current directory being the location of setup.py, using both Python 2.5.1 and Python 2.4.4. On Linux I also verified an easy_install of a tarball containing the patched setup.py works and includes the data files in the installation.

Sorry, don't have any Macs to test on but so far as I know it should work there as well.

Changed 8 years ago by Karen Tracey <kmtracey@…>

comment:2 Changed 8 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from new to closed

(In [7139]) Changed setup.py to work no matter where it is called from. We were previously
using file, which isn't consistent on Windows. Some awesome debugging (and
patch) here from Karen Tracey. Fixed #6562.

Note: See TracTickets for help on using tickets.
Back to Top