Code

Opened 6 years ago

Closed 3 years ago

#6405 closed New feature (duplicate)

ComboField/MultiValueField with FileField and passing initial data trough

Reported by: Øyvind Saltvik <oyvind@…> Owned by: nobody
Component: Forms Version: master
Severity: Normal Keywords: pass initial trough newforms multivaluefield
Cc: Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Opening new ticket for this issue first mentioned in #6302

Was thinking about FileField with deletion field and that would be done easily with a MultiValueField.

But this would not be possible since FileFields need to use initial data during validation.

Attachments (2)

combofield_multivaluefield_pass_initial_trough.diff (9.2 KB) - added by Øyvind Saltvik <oyvind@…> 6 years ago.
a new approach using isinstance and a mixin
combofield_multivaluefield_pass_initial_trough.2.diff (9.3 KB) - added by piquadrat 5 years ago.
Synced patch to trunk (other patch was in the wrong direction, sorry)

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Øyvind Saltvik <oyvind@…>

a new approach using isinstance and a mixin

comment:1 Changed 6 years ago by jacob

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Design decision needed

Changed 5 years ago by piquadrat

Synced patch to trunk (other patch was in the wrong direction, sorry)

comment:2 Changed 3 years ago by julien

  • Type set to New feature

comment:3 Changed 3 years ago by julien

  • Severity set to Normal

comment:4 Changed 3 years ago by carljm

  • Easy pickings unset
  • Resolution set to duplicate
  • Status changed from new to closed
  • UI/UX unset

Closing as duplicate of #14039, which has a fuller description of the problem and a more up to date patch.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.