Opened 8 years ago

Closed 8 years ago

#6334 closed (duplicate)

MultiWidget should return mark_safe string

Reported by: anonymous Owned by: nobody
Component: Forms Version: master
Severity: Keywords: Multiwidget auto escape
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Multiwidget should return mark_safe string in order to avoid widgets to be auto escaped.

seems that :

return self.format_output(output)

should be change in :

return mark_safe(self.format_output(output))

Attachments (1)

patch.diff (639 bytes) - added by xgdlm <grangier@…> 8 years ago.

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by xgdlm <grangier@…>

comment:1 Changed 8 years ago by mattmcc

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6113.

Note: See TracTickets for help on using tickets.
Back to Top